![]() | LibraryProfileItem Class |
The LibraryProfileItem class contains information from library profiles in
the catalog. Library profile items can be enumerated using a profile item enumerator.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The LibraryProfileItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | LibraryProfileItem |
Creates a new library profile item instance.
|

Name | Description | |
---|---|---|
![]() | aProfileItemAnalysisParameters |
An array list with the profile item analysis parameters.
|
![]() | aProfileItemParameters |
An array list with the profile item parameters.
(Inherited from ProfileItem.) |
![]() | aProfileItemUserParameters |
An array list with the profile item user parameters.
|
![]() | IsMultiCrossSectionUserParametric |
Whether the profile is a parametric user-defined multi cross section profile.
(Inherited from ProfileItem.) |
![]() | IsSketchedUserParametric |
Whether the profile is a parametric user-defined sketched profile.
(Inherited from ProfileItem.) |
![]() | NumberOfCrossSections |
The number of cross sections in the profile item.
(Inherited from ProfileItem.) |
![]() | ParameterString |
The profile item parameter string.
(Inherited from ProfileItem.) |
![]() | ProfileItemSubType |
The profile item subtype.
(Inherited from ProfileItem.) |
![]() | ProfileItemType |
The profile item type.
(Inherited from ProfileItem.) |
![]() | ProfileName |
The profile item name.
|

Name | Description | |
---|---|---|
![]() ![]() | Copy |
Copy the library profile item in the profile database to item with new name.
|
![]() | Delete |
Deletes the profile item in the profile database.
|
![]() ![]() | Export |
Exports the profile item in the profile database to given file name.
Currently library profiles, sketch profiles and clb profiles are supported.
Library profiles are exported to *.lis format.
Sketch profiles are exported to *.uel format.
Clb profiles are exported to *.clb format.
If path is not given profile is exported to model folder.
If filename is empty profile name or prefix is used as filename.
(Inherited from ProfileItem.) |
![]() ![]() | GetCrossSection |
Returns list of cross section points of inner surfaces from the profile item.
(Inherited from ProfileItem.) |
![]() | GetHighAccuracyCrossSection |
Get cross section with high accuracy.
(Inherited from ProfileItem.) |
![]() | IsProfileUserDefined |
Whether the profile is a fixed user-defined profile.
(Inherited from ProfileItem.) |
![]() | IsProfileUserParametric |
Whether the profile is a parametric user-defined profile. If so,
the prefix can be asked by type and subtype.
(Inherited from ProfileItem.) |
![]() | Modify |
Modifies the profile item in the profile database.
|
![]() | ModifyProfileItemAnalysisParameter |
Modify analysis parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.) |
![]() | ModifyProfileItemParameter |
Modify parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.) |
![]() | ModifyProfileItemUserParameter |
Modify user parameter of library profile item.
Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.) |
![]() | Select |
Selects the profile item in the profile database.
(Inherited from ProfileItem.) |
![]() | Select(String) |
Selects the profile item in the profile database using the given name.
|

It is possible to select a library profile item by its name:
using Tekla.Structures.Catalogs; public class Example { public void Example1() { LibraryProfileItem LibraryProfileItem = new LibraryProfileItem(); LibraryProfileItem.ProfileName = "HEA300"; LibraryProfileItem.Select(); //Equivalent code: LibraryProfileItem LibraryProfileItem1 = new LibraryProfileItem(); LibraryProfileItem1.Select("HEA300"); } }