API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingItemEnumerator Class

The DrawingItemEnumerator class allows to loop through the catalog drawing items.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsDrawingItemEnumerator

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class DrawingItemEnumerator : IEnumerator

The DrawingItemEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Returns a drawing item instance of the current element.
Top
Methods
  NameDescription
Public methodGetSize
Returns the total amout of items.
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Top
See Also