![]() | DrawingItem Class |
The DrawingItem class contains information from the drawings in the master drawing catalog.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The DrawingItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | DrawingItem |
Creates a new drawing item instance.
|

Name | Description | |
---|---|---|
![]() | Files |
The files belonging to drawing item.
|
![]() | Name |
The drawing item's name.
|
![]() | Type |
The files belonging to drawing item.
|

Name | Description | |
---|---|---|
![]() ![]() | Export |
Exports the drawing item in the catalog to given file name.
If path is not given drawing is exported to model folder.
If filename is empty drawing name is used as filename.
|
![]() | Select |
Selects the drawing item in the drawing catalog.
|