![]() | ComponentItemEnumerator Class |
The ComponentItemEnumerator class allows to loop through the component catalog items.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The ComponentItemEnumerator type exposes the following members.


Name | Description | |
---|---|---|
![]() | GetSize |
Returns the total amout of items.
|
![]() | MoveNext |
Moves to the next item in the enumerator.
|
![]() | Reset |
Resets the enumerator to the beginning.
|

The following example returns true if an item with the name EndPlate and with the number 144 has been found:
using Tekla.Structures.Catalogs; public class Example { public bool Example1() { bool Result = false; CatalogHandler CatalogHandler = new CatalogHandler(); if (CatalogHandler.GetConnectionStatus()) { ComponentItemEnumerator ComponentItemEnumerator = CatalogHandler.GetComponentItems(); while (ComponentItemEnumerator.MoveNext()) { ComponentItem ComponentItem = ComponentItemEnumerator.Current as ComponentItem; if (ComponentItem.Name == "EndPlate" && ComponentItem.Number == 144) { Result = true; break; } } } return Result; } }