API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ComponentItemSelect Method (String, Int32)

Selects the component item from the component database. Uses the type if defined for selection

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool Select(
	string name,
	int number
)

Parameters

name
Type: SystemString
The name of the component item to select.
number
Type: SystemInt32
The number of the component item to select.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.