![]() | ComponentItem Class |
The ComponentItem class contains information about the components in the Tekla Structures catalog.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The ComponentItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | ComponentItem |
Creates a new component item instance.
|

Name | Description | |
---|---|---|
![]() | AttributeFileExtension |
Gets the attribute file extension of item from the component database.
|
![]() | Name |
The component item's internal name which is used by Tekla Structures in component identification.
|
![]() | Number |
The component item's internal number which is used by Tekla Structures in component identification.
|
![]() | Type |
The component item's type.
|
![]() | UIName |
The component item's name which is visible in the Tekla Structures user interface.
|

Name | Description | |
---|---|---|
![]() ![]() | Export |
Exports the custom component item in *.uel-format to the to given file name.
If path is not given custom component is exported to model folder.
If filename is empty custom component name is used as filename.
|
![]() | GetVersion |
Gets the version number of custom component item from the component database.
|
![]() | Select(String, Int32) |
Selects the component item from the component database. Uses the type if defined for selection
|
![]() | Select(String, Int32, ComponentItemComponentTypeEnum) |
Selects the component item from the component database.
|