API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CatalogHandlerGetUserPropertyItems Method (CatalogObjectTypeEnum)

Returns an enumerator of user property items of the given object type.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public UserPropertyItemEnumerator GetUserPropertyItems(
	CatalogObjectTypeEnum objectType
)

Parameters

objectType
Type: Tekla.Structures.CatalogsCatalogObjectTypeEnum
The object type to be used.

Return Value

Type: UserPropertyItemEnumerator
A UserPropertyItemEnumerator of user property items of the given object type.
See Also