![]() | BoltItemEnumerator Class |
The BoltItemEnumerator class allows to loop through the bolt catalog items.

Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1

The BoltItemEnumerator type exposes the following members.


Name | Description | |
---|---|---|
![]() | GetSize |
Returns the total amout of items.
|
![]() | MoveNext |
Moves to the next item in the enumerator.
|
![]() | Reset |
Resets the enumerator to the beginning.
|

The following example returns true if an item with the standard A325N has been found:
using Tekla.Structures.Catalogs; public class Example { public bool Example1() { bool Result = false; CatalogHandler CatalogHandler = new CatalogHandler(); if (CatalogHandler.GetConnectionStatus()) { BoltItemEnumerator BoltItemEnumerator = CatalogHandler.GetBoltItems(); while (BoltItemEnumerator.MoveNext()) { BoltItem BoltItem = BoltItemEnumerator.Current as BoltItem; if (BoltItem.Standard == "A325N") { Result = true; break; } } } return Result; } }