![]() | Tekla.Structures.Catalogs Namespace |
The Tekla.Structures.Catalogs namespace includes the functionality to access Tekla Structures catalog instances, such as the profile or rebar catalog.

Class | Description | |
---|---|---|
![]() | BoltItem |
The BoltItem class contains information about the bolts in the Tekla Structures bolt catalog.
|
![]() ![]() | BoltItemEnumerator |
The BoltItemEnumerator class allows to loop through the bolt catalog items.
|
![]() | BoltName |
The BoltName class contains the name of the bolt item.
|
![]() | CatalogHandler |
The CatalogHandler class is a class from which the user can query catalog instances.
|
![]() | CatalogItemEnumeratorInitializationException |
The CatalogItemEnumeratorInitializationException class represents an error that occurred during the catalog item enumerator initialization.
This class cannot be inherited.
|
![]() | ComponentItem |
The ComponentItem class contains information about the components in the Tekla Structures catalog.
|
![]() ![]() | ComponentItemEnumerator |
The ComponentItemEnumerator class allows to loop through the component catalog items.
|
![]() ![]() | CrossSection |
The CrossSection class defines a with cross section points
|
![]() | CrossSectionPoint |
The CrossSectionPoint class defines a point with possible chamfering information
|
![]() | DrawingItem |
The DrawingItem class contains information from the drawings in the master drawing catalog.
|
![]() | DrawingItemEnumerator |
The DrawingItemEnumerator class allows to loop through the catalog drawing items.
|
![]() ![]() | LibraryProfileItem |
The LibraryProfileItem class contains information from library profiles in
the catalog. Library profile items can be enumerated using a profile item enumerator.
|
![]() | MaterialItem |
The MaterialItem class contains information about the materials in the Tekla Structures catalog.
|
![]() ![]() | MaterialItemEnumerator |
The MaterialItemEnumerator class allows to loop through the catalog material items.
|
![]() | MaterialMarketSizesItem |
The MaterialMarketSizesItem class contains information about the available market sizes for particular material.
|
![]() ![]() | MaterialMarketSizesItemEnumerator |
The MaterialMarketSizesItemEnumerator class allows to loop through the items defined in XS_PROFDB\marketsizes.dat file.
|
![]() | MaterialName |
The MaterialName class contains the name of the material item.
|
![]() | MeshItem |
The MeshItem class contains information from the meshes in the catalog
(mesh_database.inp).
|
![]() | MeshItemEnumerator |
The MeshItemEnumerator class allows to loop through the catalog mesh items.
|
![]() ![]() | ParametricProfileItem |
The ParametricProfileItem class contains information from parametric profiles in
the catalog. Parametric profile items can be enumerated using a profile item enumerator.
|
![]() | PrinterItem |
The PrinterItem class contains information about the printers in the Tekla Structures catalog.
|
![]() ![]() | PrinterItemEnumerator |
The PrinterItemEnumerator class allows to loop through the catalog printer items.
|
![]() | ProfileItem |
The ProfileItem abstract class contains the common information of catalog
profiles (parametric and library).
|
![]() ![]() | ProfileItemEnumerator |
The ProfileItemEnumerator class allows to loop through the catalog profile items.
|
![]() | ProfileItemParameter |
The ProfileItemParameter class contains the information of one profile parameter
(property name, symbol, unit and unit type). A profile item can contain a maximum
of 50 profile parameters.
|
![]() | ProfileName |
The ProfileName class contains the name of the profile item.
|
![]() | RebarHeaderItem |
The RebarHeaderItem class represents an item in the header of the rebar catalog
(rebar_database.inp).
|
![]() | RebarItem |
The RebarItem class contains information from the rebars in the catalog
(rebar_database.inp).
|
![]() | RebarItemEnumerator |
The RebarItemEnumerator class allows to loop through the catalog rebar items.
|
![]() ![]() | ShapeItem |
The Shape class contains information about the shapes in the Tekla Structures shape catalog.
|
![]() ![]() | ShapeItemEnumerator |
The ShapeItemEnumerator class allows to loop through the shape catalog items.
|
![]() | UserPropertyItem |
The UserPropertyItem class contains information about the user properties in the Tekla Structures catalog.
|
![]() ![]() | UserPropertyItemEnumerator |
The UserPropertyItemEnumerator class allows to loop through the user property items.
|
![]() | UserPropertyName |
The UserPropertyName class contains the name of the user property item.
|
![]() | UserPropertyOption |
The UserPropertyOption class contains the properties of a user property value option.
|

Enumeration | Description | |
---|---|---|
![]() | BoltItemBoltItemTypeEnum |
Defines the different bolt item types.
|
![]() | BrepType |
Shape catalog renewal makes it possible to organize shapes in the shape catalog compared to a plain list before.
Thus, it is now possible and required to distinguish shapes in such a manner that:
BuildingProduct represent shapes that users can import from, for example, Tekla Warehouse and insert them into a model.
These are usually provided by the manufacturer and not detailed by users themselves.
StructuralShape represent shapes that get created by "Convert part to item" or from geometry editing.
|
![]() | CatalogObjectTypeEnum | The catalog object type. |
![]() | ComponentItemComponentTypeEnum |
Defines the different component types.
|
![]() | MaterialItemMaterialItemTypeEnum |
Defines the different material item types.
|
![]() | ProfileItemProfileItemSubTypeEnum |
Defines the different profile item subtypes.
|
![]() | ProfileItemProfileItemTypeEnum |
Defines the different profile item types.
|
![]() | ProfileItemParameterParameterUnitTypeEnum |
Defines the different unit types of the profile item parameter.
|
![]() | ShapeUpAxis |
Up axis direction
|
![]() | UserPropertyFieldTypeEnum | The user property field type. |
![]() | UserPropertyLevelEnum | The user property level. |
![]() | UserPropertyVisibilityEnum | The visibility of the user property. |