![]() | AnalysisVolumeItem Class |
The AnalysisVolumeItem class contains information related to analysis volume items.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisVolumeItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisVolumeItem | Initializes a new instance of the AnalysisVolumeItem class |

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Faces |
The faces of the analysis volume item.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |

Name | Description | |
---|---|---|
![]() | Select |
Selects an analysis volume item.
The ID has to be set.
(Overrides AnalysisObjectSelect.) |