![]() | AnalysisRigidDiaphragm Class |
The AnalysisRigidDiaphragm class contains information related to analysis rigid diaphragms.

SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisRigidDiaphragm
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisRigidDiaphragm
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisRigidDiaphragm type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisRigidDiaphragm | Initializes a new instance of the AnalysisRigidDiaphragm class |

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | ExtremaMaximum |
The maximum of the extrema (in the global coordinate system).
|
![]() | ExtremaMinimum |
The minimum of the extrema (in the global coordinate system).
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | MasterNodeID |
The identifier of the master node.
|
![]() | PartIDs |
The part identifier.
|
![]() | SlaveNodeIDs |
The slave node identifier.
|

Name | Description | |
---|---|---|
![]() | Select |
Selects an analysis rigid diaphragm.
The ID has to be set.
(Overrides AnalysisObjectSelect.) |