![]() | AnalysisPosition Class |
The AnalysisPosition class contains information related to analysis positions.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisPosition type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisPosition | Initializes a new instance of the AnalysisPosition class |

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Node |
The node of the position.
|
![]() | Type |
The type of the position.
|

Name | Description | |
---|---|---|
![]() | Select |
Selects an analysis position.
(Overrides AnalysisObjectSelect.) |