API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisPartAreaAttributesAreaSupportEnum Enumeration

Note: This API is now obsolete.

The area support options.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
[ObsoleteAttribute("Deprecated. Please use AreaSupportTypeEnum instead.", 
	false)]
public enum AreaSupportEnum
Members
  Member nameValueDescription
AREA_SUPPORT_NONE0 The "none" area support option.
AREA_SUPPORT_WALL_BOTTOM_PINNED1 The area support simple.
AREA_SUPPORT_WALL_BOTTOM_FIXED2 The wall bottom fixed area support.
AREA_SUPPORT_ALL_PINNED3 The all pinned area support.
AREA_SUPPORT_ALL_FIXED4 The all fixed area support.
AREA_SUPPORT_OUTLINE_PINNED5 The outline pinned area support.
AREA_SUPPORT_OUTLINE_FIXED6 The outline fixed area support.
See Also