API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisPartAnalysisPropertiesAnalysisClassEnum Enumeration

The analysis classes.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public enum AnalysisClassEnum
Members
  Member nameValueDescription
ANALYSIS_CLASS_COLUMN1 The column analysis class.
ANALYSIS_CLASS_BEAM2 The beam analysis class.
ANALYSIS_CLASS_WALL3 The wall analysis class.
ANALYSIS_CLASS_SLAB4 The slab analysis class.
ANALYSIS_CLASS_CONTOUR_PLATE5 The contour plate analysis class.
ANALYSIS_CLASS_SECONDARY99 The old secondary object analysis class. Named now as bracing.
ANALYSIS_CLASS_BRACING99 The bracing object analysis class.
ANALYSIS_CLASS_SECONDARY_MEMBER100 The secondary object analysis class.
See Also