API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisObjectSelectorGetAllObjectsWithType Method

Returns an enumerator of all the model objects in the current model with the given type.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public AnalysisObjectEnumerator GetAllObjectsWithType(
	AnalysisObjectAnalysisObjectEnum ObjectToSelectType,
	string AnalysisModelName
)

Parameters

ObjectToSelectType
Type: Tekla.Structures.AnalysisAnalysisObjectAnalysisObjectEnum
The type of the objects to return.
AnalysisModelName
Type: SystemString
The name of the analysis model.

Return Value

Type: AnalysisObjectEnumerator
A model object enumerator of all the model objects with the given type.
See Also