API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisObjectEnumeratorGetEnumerator Method

Returns a pointer to the existing instance of the class. This allows the usage of the foreach statement with AnalysisObjectEnumerator.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public IEnumerator GetEnumerator()

Return Value

Type: IEnumerator
The pointer to the existing instance of the class.
See Also