![]() | AnalysisNodeLink Class |
The AnalysisNodeLink class contains information related to analysis node links.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisNodeLink type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisNodeLink |
Initializes a new instance of the AnalysisNodeLink class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | CoordinateSystem |
The coordinate system of the analysis node link.
|
![]() | Disabled |
Indicates whether the analysis node link is disabled.
|
![]() | EndConnectivity |
The end connectivity of the analysis node link.
|
![]() | EndNode |
The end node.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | IsUserConnectivity |
Indicates whether the analysis node has a user defined connectivity.
|
![]() | IsUserNodeLink |
Indicates whether the analysis node is a user node link.
|
![]() | OwnerPartIDs |
The list of the identifiers of the owner parts.
|
![]() | StartConnectivity |
The start connectivity of the analysis node link.
|
![]() | StartNode |
The start node.
|

Name | Description | |
---|---|---|
![]() | Delete |
Deletes a user analysis node link.
The ID has to be set.
|
![]() | Insert |
Inserts a user analysis node link.
The AnalysisModelName has to be set.
The StartNodeID has to be set.
The EndNodeID has to be set.
|
![]() | Modify |
Modifies an analysis node link.
The ID has to be set.
|
![]() | Select |
Selects an analysis node link.
The ID has to be set.
(Overrides AnalysisObjectSelect.) |