API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisModelHandlerAddPart Method

Adds a part to the analysis model. The ConstructionMethod must be SELECTED_PARTS, SELECTED_PARTS_AND_LOADS or FLOOR_BY_SELECTED_PARTS_AND_LOADS.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public void AddPart(
	AnalysisModel AnalysisModel,
	Part ModelPart
)

Parameters

AnalysisModel
Type: Tekla.Structures.AnalysisAnalysisModel
The analysis model to be used.
ModelPart
Type: Tekla.Structures.ModelPart
The model part to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.