API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisModelDesignProperties Class

The AnalysisModelDesignProperties class contains information related to analysis model design properties.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisModelDesignProperties

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public sealed class AnalysisModelDesignProperties

The AnalysisModelDesignProperties type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisModelDesignProperties
Initializes a new instance of the AnalysisModelDesignProperties class
Top
Properties
  NameDescription
Public propertyConcreteDesign
The concrete code used.
Public propertyConcreteDesignMethod
The concrete design method.
Public propertySteelDesign
The steel code used.
Public propertySteelDesignMethod
The steel design method.
Public propertyTimberDesign
The timber code used.
Public propertyTimberDesignMethod
The timber design method.
Top
See Also