AnalysisModelConnectivityRule Class

The AnalysisModelConnectivityRule class contains information related to analysis model connectivity rules.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObject
    Tekla.Structures.AnalysisAnalysisModelConnectivityRule

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisModelConnectivityRule : AnalysisObject

The AnalysisModelConnectivityRule type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisModelConnectivityRule
Initializes a new instance of the AnalysisModelConnectivityRule class
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyGroup1
The group name 1 of the connectivity rule.
Public propertyGroup2
The group name 2 of the connectivity rule.
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyLinkage1
The linkage 1 of the connectivity rule.
Public propertyLinkage2
The linkage 2 of the connectivity rule.
Public propertyMagneticDistance
The magnetic distance of the connectivity rule.
Public propertyStatus
The status of the connectivity rule.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next