AnalysisModelConnectivityRule Class

The AnalysisModelConnectivityRule class contains information related to analysis model connectivity rules.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisObject
    Tekla.Structures.AnalysisAnalysisModelConnectivityRule

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisModelConnectivityRule : AnalysisObject

The AnalysisModelConnectivityRule type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisModelConnectivityRule
Initializes a new instance of the AnalysisModelConnectivityRule class
Top
Properties
  NameDescription
Public propertyGroup1
The group name 1 of the connectivity rule.
Public propertyGroup2
The group name 2 of the connectivity rule.
Public propertyLinkage1
The linkage 1 of the connectivity rule.
Public propertyLinkage2
The linkage 2 of the connectivity rule.
Public propertyMagneticDistance
The magnetic distance of the connectivity rule.
Public propertyStatus
The status of the connectivity rule.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next