![]() | AnalysisMember Class |
The AnalysisMember class contains information related to analysis members.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisMember type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisMember |
Initializes a new instance of the AnalysisMember class.
|

Name | Description | |
---|---|---|
![]() | AnalysisDesignCode |
Gets or sets the analysis design code of the member.
|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Composite |
Gets or sets the composite settings of the member.
|
![]() | Curvature |
Gets or sets the beam curvature of the member.
|
![]() | End |
Gets or sets the analysis beam end settings at the end of the member.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Label |
Gets or sets the label of the analysis member.
|
![]() | Material |
Gets or sets the material of the analysis member.
|
![]() | Start |
Gets or sets the analysis beam end settings at the start of the member.
|

Name | Description | |
---|---|---|
![]() | CopyData |
Copies data from another analysis member.
|
![]() | Modify |
Modifies an analysis member.
The AnalysisModelName has to be set.
|
![]() | Select |
Selects an analysis member.
The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.) |