![]() | AnalysisMaterial Class |
The AnalysisMaterial class contains the material information.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisMaterial type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisMaterial |
Initializes a new instance of the AnalysisMaterial class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | DampingFactor |
Gets or sets the damping factor of the material.
|
![]() | Density |
Gets or sets the density of the material.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | MaterialType |
Gets or sets tThe type of the material.
|
![]() | ModulusOfElasticity |
Gets or sets the modulus of elasticity of the analysis material.
|
![]() | Name |
Gets or sets the name of the analysis material.
|
![]() | PoissonsRatio |
Gets or sets the Poisson's ratio of the analysis material.
|
![]() | ThermalDilatation |
Gets or sets the thermal dilatation of the analysis material.
|

Name | Description | |
---|---|---|
![]() | Select |
Selects an analysis material.
The AnalysisModelName and Name have to be set.
(Overrides AnalysisObjectSelect.) |