![]() | AnalysisLoadGroup Class |
The AnalysisLoadGroup class contains information related to analysis load groups.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisLoadGroup type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisLoadGroup |
Initializes a new instance of the AnalysisLoadGroup class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Compatible |
Gets or sets a value indicating whether the load group is compatible.
|
![]() | CompatibleNumber |
Gets or sets the load group compatible number.
|
![]() | Direction |
Gets or sets the direction of the load group.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Incompatible |
Gets or sets a value indicating whether the load group is incompatible.
|
![]() | IncompatibleNumber |
Gets or sets the load group incompatible number.
|
![]() | LoadGroupID |
Gets or sets the identifier of the load group.
|
![]() | Name |
Gets or sets the name of the load group.
|
![]() | Type |
Gets or sets the type of the load group.
|

Name | Description | |
---|---|---|
![]() ![]() | GetTypeName |
Get load group type name, translated to current language.
|
![]() | IsEmpty |
Check if load group is empty (no loading exists).
|
![]() | IsSelfWeight |
Check if load group is self weight load group.
|
![]() | Select |
Selects an AnalysisLoadGroup.
The ID has to be set.
(Overrides AnalysisObjectSelect.) |