![]() | AnalysisLoadCombination Class |
The AnalysisLoadCombination class contains information related to analysis load combinations.

SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisLoadCombination
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisLoadCombination
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisLoadCombination type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisLoadCombination |
Initializes a new instance of the AnalysisLoadCombination class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | GroupIDs |
Gets or sets the identifiers of the groups of the analysis load combination.
|
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Name |
Gets or sets the name of the analysis load combination.
|
![]() | PartialSafetyFactors |
Gets or sets the partial safety factors of the analysis load combination.
|
![]() | ReductionFactors |
Gets or sets the reduction factors of the analysis load combination.
|
![]() | ScalingFactors |
Gets or sets the scaling factors of the analysis load combination.
|
![]() | Type |
Gets or sets the combination type of the analysis load combination.
|

Name | Description | |
---|---|---|
![]() | Delete |
Deletes an analysis load combination.
The AnalysisModelName and ID have to be set.
|
![]() | Insert |
Inserts an analysis load combination.
The AnalysisModelName has to be set.
|
![]() | Modify |
Modifies an analysis load combination.
The AnalysisModelName and ID have to be set.
|
![]() | Select |
Selects an analysis load combination.
The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.) |
![]() | SetLoads |
Sets the loads.
|