![]() | AnalysisEdge Class |
The AnalysisEdge class contains information related to analysis edges.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisEdge type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisEdge |
Creates a new instance of the AnalysisEdge class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Connectivity |
The connectivity of the analysis edge.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Radius |
The radius of the analysis edge.
|
![]() | SplitPositions |
The split positions of the analysis edge.
|

Name | Description | |
---|---|---|
![]() | AddSplit |
Adds a split position to the analysis edge.
|
![]() | CopyData |
Copies data from another analysis edge.
|
![]() | GetSplitPositions |
Gets the split positions of the analysis edge.
|
![]() | Modify |
Modifies an analysis edge.
The AnalysisModelName has to be set.
|
![]() | Select |
Selects an analysis edge.
(Overrides AnalysisObjectSelect.) |