API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisDesignParameterMulti Constructor (String, Int32, Identifier)

Initializes a new instance of the AnalysisDesignParameterMulti class.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public AnalysisDesignParameterMulti(
	string analysisModelName,
	int parameterId,
	Identifier partId
)

Parameters

analysisModelName
Type: SystemString
The analysis model name.
parameterId
Type: SystemInt32
The analysis design parameter ID.
partId
Type: Tekla.StructuresIdentifier
The father part ID.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.