![]() | AnalysisDesignParameterBase Class |
The AnalysisDesignParameterBase class contains base information related to analysis design parameters.

SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDesignParameterBase
Tekla.Structures.AnalysisAnalysisDesignParameter
Tekla.Structures.AnalysisAnalysisDesignParameterMulti
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDesignParameterBase
Tekla.Structures.AnalysisAnalysisDesignParameter
Tekla.Structures.AnalysisAnalysisDesignParameterMulti
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisDesignParameterBase type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | IsGeneral |
Gets or sets a value indicating whether the design parameter is general.
|
![]() | Name |
Gets or sets the name of the analysis design parameter.
|
![]() | Unit |
Gets or sets the unit of the analysis design parameter.
|

Name | Description | |
---|---|---|
![]() | Modify |
Modifies an analysis design parameter at the database.
Inserts if parameter does not exist.
|
![]() | Select |
Selects an analysis object from the database.
(Inherited from AnalysisObject.) |