![]() | AnalysisDecomposedTemperatureLoad Class |
The AnalysisDecomposedTemperatureLoad class contains information related to decomposed temperature loads.

SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedTemperatureLoad
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedTemperatureLoad
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisDecomposedTemperatureLoad type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisDecomposedTemperatureLoad | Initializes a new instance of the AnalysisDecomposedTemperatureLoad class |

Name | Description | |
---|---|---|
![]() | AnalysisLoadType |
Gets or sets the type of the analysis decomposed load.
(Inherited from AnalysisDecomposedLoad.) |
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | AxialTemperatureDifference |
The axial temperature difference of the decomposed temperature load.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | HorizontalTemperatureDifference |
The horizontal temperature difference of the decomposed temperature load.
|
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | ModelLoadGroupID |
Gets or sets the identifier of the load group.
(Inherited from AnalysisDecomposedLoad.) |
![]() | ModelLoadID |
Gets or sets the identifier of the model load.
(Inherited from AnalysisDecomposedLoad.) |
![]() | ObjectAttachedToID |
Gets or sets the identifier of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.) |
![]() | ObjectAttachedToType |
Gets or sets the type of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.) |
![]() | Strain |
The strain of the decomposed temperature load.
|
![]() | VerticalTemperatureDifference |
The vertical temperature difference of the decomposed temperature load.
|

Name | Description | |
---|---|---|
![]() | Select |
Selects an analysis decomposed temperature load.
(Overrides AnalysisObjectSelect.) |