API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisDecomposedSelfweightLoad Class

The AnalysisDecomposedSelfweightLoad class contains information of decomposed selfweight loads.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public sealed class AnalysisDecomposedSelfweightLoad : AnalysisDecomposedLoad

The AnalysisDecomposedSelfweightLoad type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisDecomposedSelfweightLoad
Initializes a new instance of the AnalysisDecomposedSelfweightLoad class
Top
Properties
  NameDescription
Public propertyDirections
The directions of the decomposed selfweight load.
Public propertyFactors
The factors of the decomposed selfweight load.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.