API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisCurvature Class

The AnalysisCurvature class contains information related to analysis curvatures.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisCurvature

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public sealed class AnalysisCurvature

The AnalysisCurvature type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisCurvature
Initializes a new instance of the AnalysisCurvature class
Top
Properties
  NameDescription
Public propertyRadius
The radius of the beam curvature.
Public propertyRadiusDirection
The radius direction of the beam curvature.
Top
See Also