![]() | AnalysisCrossSection Class |
The AnalysisCrossSection class contains information related to analysis cross sections.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisCrossSection type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisCrossSection |
Creates a new instance of an analysis cross section.
|

Name | Description | |
---|---|---|
![]() | A |
The cross section area (m2) of the analysis cross section.
|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | AnalysisSubSections |
The subsections of the analysis cross section.
|
![]() | Avy |
The shear area for loads parallel to the Y-axis (m2) of the analysis cross section.
|
![]() | Avz |
The shear area for loads parallel to the Z-axis (m2) of the analysis cross section.
|
![]() | Calculated |
Indicates whether section values have been calculated.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | G |
The mass per unit of length (kg/m) of the analysis cross section.
|
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | It |
The torsion moment (m4) of the analysis cross section.
|
![]() | Iw |
The warping constant (m6) of the analysis cross section.
|
![]() | Iy |
The radius of gyration about the Y-axis (m) of the analysis cross section.
|
![]() | Iyy |
The moment of inertia about the Y-axis (m4) of the analysis cross section.
|
![]() | Iz |
The radius of gyration about the Z-axis (m) of the analysis cross section.
|
![]() | Izz |
The moment of inertia about the Z-axis (m4) of the analysis cross section.
|
![]() | Name |
The name of the analysis cross section.
|
![]() | Wplyy |
The plastic modulus about the Y-axis (m3) of the analysis cross section.
|
![]() | Wplzz |
The plastic modulus about the Z-axis (m3) of the analysis cross section.
|
![]() | Wyy |
The elastic modulus about the Y-axis (m3) of the analysis cross section.
|
![]() | Wzz |
The elastic modulus about the Z-axis (m3) of the analysis cross section.
|

Name | Description | |
---|---|---|
![]() | Delete |
Deletes an analysis cross section.
The AnalysisModelName and ID have to be set.
|
![]() | GetCrossSectionGroup |
Gets the cross section group.
|
![]() | Insert |
Inserts an analysis cross section.
The AnalysisModelName has to be set.
|
![]() | Select |
Selects an analysis cross section.
The AnalysisModelName and ID/Name have to be set.
(Overrides AnalysisObjectSelect.) |