API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AnalysisCompositeBeam Class

The AnalysisCompositeBeam class contains information related to analysis composite beams.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.AnalysisAnalysisCompositeBeam

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1
Syntax
public sealed class AnalysisCompositeBeam

The AnalysisCompositeBeam type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisCompositeBeam
Initializes a new instance of the AnalysisCompositeBeam class
Top
Properties
  NameDescription
Public propertyComposite
Indicates whether the beam is composite.
Public propertyConcreteStrength
The strength of the concrete of the analysis composite beam.
Public propertyRibDirection
The direction of the rib of the analysis composite beam (in the global coordinate system).
Public propertyRibHeight
The height of the rib of the analysis composite beam.
Public propertyRibWidth
The width of the rib of the analysis composite beam.
Public propertySlabMaterial
The slab material of the analysis composite beam.
Public propertySlabThickness
The thickness of the slab of the analysis composite beam.
Public propertySlabWidthLeft
The left width of the slab of the analysis composite beam.
Public propertySlabWidthRight
The right width of the slab of the analysis composite beam.
Public propertyStudDiameter
The diameter of the stud of the analysis composite beam.
Public propertyStudLength
The length of the stud of the analysis composite beam.
Top
See Also