![]() | AnalysisAreaPolygon Class |
The AnalysisAreaPolygon class contains information related to analysis area polygons.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisAreaPolygon type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisAreaPolygon |
Creates a new instance of the AnalysisAreaPolygon class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Edges |
The edges of the area polygon.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | Positions |
The positions of the area polygon.
|

Name | Description | |
---|---|---|
![]() | Add |
Adds a position to the analysis area polygon.
Also adds an edge.
|
![]() | GetEdges |
Gets the edges of the area polygon.
|
![]() | GetPositions |
Gets the positions of the area polygon.
|
![]() | Insert |
Inserts an analysis area polygon.
The AnalysisModelName has to be set.
|
![]() | Select |
Selects an analysis area polygon.
The AnalysisObjectType has to be set.
(Overrides AnalysisObjectSelect.) |