![]() | AnalysisArea Class |
The AnalysisArea class contains information related to analysis areas.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.1

The AnalysisArea type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisArea |
Initializes a new instance of the AnalysisArea class.
|

Name | Description | |
---|---|---|
![]() | AnalysisDesignCode |
Gets or sets the design code of the analysis area.
|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | AnalysisType |
Gets or sets the analysis type of the analysis area.
|
![]() | Area |
Gets or sets the area polygon of the analysis area.
|
![]() | AreaHoles |
Gets or sets the area holes of the analysis area.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | InnerPositions |
Gets or sets the inner positions of the analysis area.
|
![]() | Label |
Gets or sets the label of the analysis area.
|
![]() | Material |
Gets or sets the material of the analysis area.
|
![]() | Profile |
Gets or sets the profile of the analysis area.
|
![]() | RigidDiaphragm |
Gets or sets the rigid diaphragm of the analysis area.
|
![]() | Thickness |
Gets or sets the thickness of the analysis area.
|

Name | Description | |
---|---|---|
![]() | Delete |
Deletes an analysis area.
Method is not implemented yet.
|
![]() | GetAreaHoles |
Gets the area holes of the analysis area.
|
![]() | GetInnerPositions |
Gets the inner positions of the analysis area.
|
![]() | Modify |
Modifies an analysis area.
Method is not implemented yet.
|
![]() | Select |
Selects an analysis area.
The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.) |