API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresVariables Class

The EnvironmentVariables class contains a sorted list specializing in getting active environment variables and advanced option settings. It also checks options.ini files in the active model folder as well as options_user.ini files.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresTeklaStructuresVariables

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static class TeklaStructuresVariables

The TeklaStructuresVariables type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd
Adds a variable to the list.
Public methodStatic memberContainsVariable
Gets a key.
Public methodStatic memberGet
Gets a key.
Top
Fields
  NameDescription
Public fieldStatic memberPourManagementOptionName
The advanced option name for pour management.
Top
See Also