API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresSettingsSetOptions Method (ComponentOptions)

Sets the component options.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool SetOptions(
	ComponentOptions Options
)

Parameters

Options
Type: Tekla.StructuresComponentOptions
The component options to be set.

Return Value

Type: Boolean
True if the component options were successfully set.
Exceptions
ExceptionCondition
ArgumentNullExceptionOptions cannot be null
OverflowExceptionFolded Plate Profile Name is too long or Plate Profile Name is too long or Bolt Standard is too long or Bolt Size is too long or Part Material is too long or or or or
See Also