API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresSettingsSetOptions Method (ClashCheckOptions)

Sets the clash check options.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool SetOptions(
	ClashCheckOptions Options
)

Parameters

Options
Type: Tekla.StructuresClashCheckOptions
The clash check options to be set.

Return Value

Type: Boolean
True if the clash check options were successfully set.
See Also