API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresSettingsGetOptions Method (ComponentOptions)

Returns the value of the component options.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool GetOptions(
	ref ComponentOptions Options
)

Parameters

Options
Type: Tekla.StructuresComponentOptions
The returned value of the component options.

Return Value

Type: Boolean
True if the values were successfully retrieved.
See Also