API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresSettingsGetOptions Method (ClashCheckOptions)

Returns the value of the clash check options.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool GetOptions(
	ref ClashCheckOptions Options
)

Parameters

Options
Type: Tekla.StructuresClashCheckOptions
The returned value of the clash check options.

Return Value

Type: Boolean
True if the values were successfully retrieved.
See Also