API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresSettingsGetAdvancedOption Method (String, Int32)

Returns the value of an advanced option variable.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool GetAdvancedOption(
	string VariableName,
	ref int Value
)

Parameters

VariableName
Type: SystemString
The name of the advanced option.
Value
Type: SystemInt32
The returned value of the advanced option.

Return Value

Type: Boolean
True if the value was successfully retrieved.
See Also