![]() | TeklaStructuresFiles Class |
The TeklaStructuresFiles class is for the paths where the attributes file will be searched for.

Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

The TeklaStructuresFiles type exposes the following members.

Name | Description | |
---|---|---|
![]() | TeklaStructuresFiles |
Initializes a new instance of the TeklaStructuresFiles class.
|

Name | Description | |
---|---|---|
![]() | PropertyFileDirectories |
The directories where to look for property files.
|

Name | Description | |
---|---|---|
![]() | GetAttributeFile(String) |
Gets a file info representing the first match in the standard property file directories.
|
![]() | GetAttributeFile(ListString, String) |
Gets a file info representing the first match in the search directories.
|
![]() | GetMultiDirectoryFileList |
Gets a list of files with the given extension from the default search directories.
|