![]() | ComponentOptions Class |
The ComponentOptions class represents the component options.

Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

The ComponentOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | ComponentOptions | Initializes a new instance of the ComponentOptions class |

Name | Description | |
---|---|---|
![]() | AssemblyLoosePartPositionPrefix | The assembly loose position prefix. |
![]() | AssemblyLoosePartStartNumber | The assembly loose part number. |
![]() | BoltEdgeDistanceFactor | The factor of bolt edge distance. |
![]() | BoltEdgeDistanceReference | The bolt edge distance reference. |
![]() | BoltSize | The bolt size. |
![]() | BoltStandard | The bolt standard. |
![]() | FoldedPlateProfileName | The folded plate profile name. |
![]() | LoosePartPositionPrefix | The loose part position prefix. |
![]() | LoosePartStartNumber | The loose part start number. |
![]() | PartMaterial | The part material. |
![]() | PartWeldedToPrimaryPositionPrefix | The part welded to primary position prefix. |
![]() | PartWeldedToPrimaryStartNumber | The part welded to primary start number. |
![]() | PartWeldedToSecondaryPositionPrefix | The part welded to secondary position prefix. |
![]() | PartWeldedToSecondaryStartNumber | The part welded to secondary start number. |
![]() | PlateProfileName | The plate profile name. |