API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ComponentDefinitionTypeEnum Enumeration

The component definition type tells what kind of a component is in question.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public enum ComponentDefinitionTypeEnum
Members
  Member nameValueDescription
SYSTEM0 With the type system, component is defined using developer-kit
CUSTOM-1 With the type custom, component is defined as custom component
DOTNET-100000 With the type dotnet, component is defined using .NET plug-in interface
DOTNET_CONNECTION-200000 With the type dotnet_connection, connection is defined using .NET plug-in interface
DOTNET_DRAWING-300000 With the type dotnet_drawing, drawing component is defined using .NET drawing plug-in interface
See Also