API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ClashCheckOptions Class

The ClashCheckOptions class represents the clash check options.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresClashCheckOptions

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class ClashCheckOptions

The ClashCheckOptions type exposes the following members.

Constructors
  NameDescription
Public methodClashCheckOptions
Initializes a new instance of the ClashCheckOptions class
Top
Properties
  NameDescription
Public propertyBoltHeadDiameter
The bolt head diameter.
Public propertyNutThickness
The nut thickness.
Top
See Also