API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Assertion Constructor

Initializes a new instance of the Assertion class.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Assertion(
	string message,
	string detailedMessage,
	string methodName
)

Parameters

message
Type: SystemString
The message.
detailedMessage
Type: SystemString
The detailed message.
methodName
Type: SystemString
The method name.
Exceptions
ExceptionCondition
ArgumentNullException
See Also