API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Assertion Class

Defines an assertion by the method it failed in and the messages it provided.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresAssertion

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public class Assertion

The Assertion type exposes the following members.

Constructors
  NameDescription
Public methodAssertion
Initializes a new instance of the Assertion class.
Top
Properties
  NameDescription
Public propertyDetailedMessage
Gets the detailed message provided by the assertion.
Public propertyMessage
Gets the message provided by the assertion.
Public propertyMethodName
Gets the name of the method the assertion failed in.
Top
Methods
See Also