API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BoltHoleAttributes Class

The bolt hole attributes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelBoltHoleAttributes

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class BoltHoleAttributes

The BoltHoleAttributes type exposes the following members.

Constructors
  NameDescription
Public methodBoltHoleAttributes
Creates a new bolt hole attributes instance.
Top
Properties
  NameDescription
Public propertyHoleType
The special hole type: oversized, tapped, slotted, blind or no hole.
Public propertyLongHoleX
The long hole X value.
Public propertyLongHoleY
The long hole Y value.
Public propertySlotOffsetX
The slot offset X value.
Public propertySlotOffsetY
The slot offset Y value.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.