API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerSetActiveDrawing Method (Drawing, Boolean, Boolean)

Sets the active drawing that is currently open in Tekla Structures.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool SetActiveDrawing(
	Drawing drawing,
	bool showDrawing,
	bool forceOpen
)

Parameters

drawing
Type: Tekla.Structures.DrawingDrawing
The drawing to be set as the active drawing.
showDrawing
Type: SystemBoolean
Whether to open the drawing as visible or in the background (faster).
forceOpen
Type: SystemBoolean
Force to open the drawing even if it is not up to date. showDrawing needs to be set to false to be able to use forceOpen

Return Value

Type: Boolean
True on success.
Exceptions
ExceptionCondition
CannotPerformOperationDrawingNotUpToDateExceptionThrown if the drawing is not up to date.
See Also