API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MateriaClientAdapterLoadGraph Method (Asset, ListGraphParameter)

Loads the graph corresponding to the specified uri providing the explicit parameter values and retrieves it's GUID

Namespace:  Tekla.Structures.TeklaStructuresInternal.MateriaClient
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Task<IGraph> LoadGraph(
	Asset asset,
	List<GraphParameter> graphParameters
)

Parameters

asset
Type: Tekla.Structures.TeklaStructuresInternal.MateriaClientAsset

[Missing <param name="asset"/> documentation for "M:Tekla.Structures.TeklaStructuresInternal.MateriaClient.MateriaClientAdapter.LoadGraph(Tekla.Structures.TeklaStructuresInternal.MateriaClient.Asset,System.Collections.Generic.List{Tekla.Structures.TeklaStructuresInternal.MateriaClient.GraphParameter})"]

graphParameters
Type: System.Collections.GenericListGraphParameter
The list of parameters

Return Value

Type: TaskIGraph
The GUID of the loaded graph as a string, or empty string if the graph loading didn't succeed.

Implements

IMateriaClientAdapterLoadGraph(Asset, ListGraphParameter)
See Also