API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IGraphGetTrimBimToFile Method

Retrieves the geometry as TrimBIM and writes it to the specified file.

Namespace:  Tekla.Structures.TeklaStructuresInternal.MateriaClient
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
Task<bool> GetTrimBimToFile(
	string path
)

Parameters

path
Type: SystemString
The path where the TrimBIM is written.

Return Value

Type: TaskBoolean
True if the TrimBIM is written to the file, false otherwise.
See Also